HDOJ3732--Ahui Writes Word--多重背包

Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)

Output
Output the maximum value in a single line for each test case.

Sample Input
  
  
5 20 go 5 8 think 3 7 big 7 4 read 2 6 write 3 5

Sample Output
  
  
15
Hint
Input data is huge,please use “scanf(“%s”,s)”
/*
首先统计每一种石头的个数
然后二进制优化,因为无论对一种石头取多少个,都可以分解为不同n的2^n之和。
然后就是0-1背包问题了呵呵
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;
int st[11][11];
int xinstv[100008];//用来存新石头的价值
int xinstw[100008];//用来存新石头的体积
int dp[10008];
inline int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int n,c;//n上限是10W,c上限是1w
	while(scanf("%d%d",&n,&c)==2)
	{
		char a[12];
		int v,w;//v是价值,w是单词的复杂度。以下把单词当石头,复杂度当体积
		memset(st,0,sizeof(st));
		for(int i=1;i<=n;i++)
		{
			scanf("%s%d%d",a,&v,&w);
			st[v][w]++;//st[v][w]表示价值为v,体积为w的石头
		}
		/*接下来要进行二进制优化,就是把一堆石头拆成1个,2个,4个,8个,16个。。等等的小堆
		这样的一堆组成一个新石头。问题转化为对象为新石头的0-1背包问题*/
		int k=1;
		for(int i=0;i<=10;i++)//
		{
			for(int j=0;j<=10;j++)
			{
				if(st[i][j])
				{
					int temp=1;
					while(st[i][j]>temp)//st[i][j]表示价值为i,体积为j的石头
					{
						xinstv[k]=temp*i;
						xinstw[k++]=temp*j;
						st[i][j]-=temp;
						temp*=2;
					}
					xinstv[k]=st[i][j]*i;
					xinstw[k++]=st[i][j]*j;
				}
			}
		}
		//现在就是个在k-1个石头,体积为c的0-1背包问题了
		memset(dp,0,sizeof(dp));
		for(int i=1;i<k;i++)
		{
			for(int j=c;j>=xinstw[i];j--)
			{
				dp[j]=max(dp[j],dp[j-xinstw[i]]+xinstv[i]);
			}
		}
		printf("%d\n",dp[c]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值