HDU1856--More is better


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8

Sample Output
4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result.In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 

/*
这题我觉得主要就是按权值合并那里修改一下即可
注意n为0的情况和i到i的情况
*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 10000000
int father[maxn+8];
int rank1[maxn+8];
int maxsum=0;
void init()
{
	for(int i=1;i<=maxn+4;i++)
	{
		father[i]=i;
	}
}
int find(int x)
{
	if(x==father[x])return x;
	return father[x]=find(father[x]);
}
void Union(int a,int b)
{
	int aa=find(a);
	int bb=find(b);
	father[aa]=bb;
	rank1[bb]+=rank1[aa]+1;
	if(rank1[bb]+1>maxsum)
	{
		maxsum=rank1[bb]+1;
	}
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		init();
		maxsum=0;
		memset(rank1,0,sizeof(rank1));
		bool flag=true;
		for(int i=1;i<=n;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			if(find(u)!=find(v))
			{
				Union(u,v);
				flag=false;
			}
		}
		if(!n||flag)printf("%d\n",1);
		else printf("%d\n",maxsum);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值