More is better(并差集)

More is better

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output
4
2
核心代码:在并差集的合并中改代码,找一棵节点最多的树

void mix(int a,int b)
{
	int fx=find(a);
	int fy=find(b);
	if(fx!=fy)
	{
	  pre[fx]=fy;
	  mark[fy]+=mark[fx];//记录每棵树的节点数 
	 if(mark[fy]>countt)
	 countt=mark[fy];	
	}	
}

例如:在给的第一组数据中
1 2 3 4 5 6 1 6
在这里插入图片描述

#include<cstdio>
#include<cmath>
#include<algorithm>
#define N 10000005
int pre[N],mark[N],countt;
using namespace std;
int find(int x)
{
	int r=x;
	while(pre[r]!=r)
	r=pre[r];
	
	int i=x,j;
	while(i!=r)
	{
	 j=pre[i];
	 pre[i]=r;
	 i=j;
	}
	return r;
}

void init()
{
	for(int i=0;i<=N;i++)
	{
		pre[i]=i;
		mark[i]=1;
	}
}

void mix(int a,int b)
{
	int fx=find(a);
	int fy=find(b);
	if(fx!=fy)
	{
	  pre[fx]=fy;
	  mark[fy]+=mark[fx];//记录每棵树的节点数
	 
	 if(mark[fy]>countt)
	 countt=mark[fy];	
	}	
}

int main()
{
	int t,p1,p2;
	while(scanf("%d",&t)!=EOF)
	{
		countt=1;
		init();
		while(t--)
		{
			scanf("%d %d",&p1,&p2);
			mix(p1,p2);
		 }
	     printf("%d\n",countt);
	}
	return 0;
}

我本来想用map写 嘻嘻但是存储超限 而且运行太慢

#include<cstdio>
#include<cmath>
#include<algorithm>
#define N 10000005
int pre[N],mark[N],countt;
#include <map>
using namespace std;
map <int,int>mp;
int find(int x)
{
    int r=x;
    while(pre[r]!=r)
    r=pre[r];
    
    int i=x,j;
    while(i!=r)
    {
     j=pre[i];
     pre[i]=r;
     i=j;
    }
    return r;
}

void init()
{
    for(int i=0;i<=N;i++)
    {
        pre[i]=i;
        mark[i]=0;
    }
}

void mix(int a,int b)
{
    int fx=find(a);
    int fy=find(b);
    if(fx!=fy)
    {
      pre[fx]=fy;
      //mark[fy]+=mark[fx];//记录每棵树的节点数
     //mp[fy]++;
     // if(mp[fy]>countt)
     // countt=mp[fy];    
    }    
}

int main()
{
    int t,p1,p2;
    while(scanf("%d",&t)!=EOF)
    {
        if(t==0)
        {
        printf("1\n");
        continue;
        }
        countt=0;
        init();
        while(t--)
        {
            scanf("%d %d",&p1,&p2);
            mix(p1,p2);
            mark[p1]=1,mark[p2]=1;
            
         }
        for(int i=0;i<=N;i++)
        {
            if(mark[i])
            mp[find(i)]++;
        }
         for(int i=0;i<=N;i++)
         {
         if(mp[i]>countt)
         countt=mp[i];
         } 
         printf("%d\n",countt);
         mp.clear(); 
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值