POJ1054--The Troublesome Frog

Description

In Korea, the naughtiness of the cheonggaeguri, a small frog, is legendary. This is a well-deserved reputation, because the frogs jump through your rice paddy at night, flattening rice plants. In the morning, after noting which plants have been flattened, you want to identify the path of the frog which did the most damage. A frog always jumps through the paddy in a straight line, with every hop the same length:  
 
Your rice paddy has plants arranged on the intersection points of a grid as shown in Figure-1, and the troublesome frogs hop completely through your paddy, starting outside the paddy on one side and ending outside the paddy on the other side as shown in Figure-2:  
 
Many frogs can jump through the paddy, hopping from rice plant to rice plant. Every hop lands on a plant and flattens it, as in Figure-3. Note that some plants may be landed on by more than one frog during the night. Of course, you can not see the lines showing the paths of the frogs or any of their hops outside of your paddy ?for the situation in Figure-3, what you can see is shown in Figure-4:  
 
From Figure-4, you can reconstruct all the possible paths which the frogs may have followed across your paddy. You are only interested in frogs which have landed on at least 3 of your rice plants in their voyage through the paddy. Such a path is said to be a frog path. In this case, that means that the three paths shown in Figure-3 are frog paths (there are also other possible frog paths). The vertical path down column 1 might have been a frog path with hop length 4 except there are only 2 plants flattened so we are not interested; and the diagonal path including the plants on row 2 col. 3, row 3 col. 4, and row 6 col. 7 has three flat plants but there is no regular hop length which could have spaced the hops in this way while still landing on at least 3 plants, and hence it is not a frog path. Note also that along the line a frog path follows there may be additional flattened plants which do not need to be landed on by that path (see the plant at (2, 6) on the horizontal path across row 2 in Figure-4), and in fact some flattened plants may not be explained by any frog path at all.  

Your task is to write a program to determine the maximum number of landings in any single frog path (where the maximum is taken over all possible frog paths). In Figure-4 the answer is 7, obtained from the frog path across row 6.  

Input

Your program is to read from standard input. The first line contains two integers R and C, respectively the number of rows and columns in your rice paddy, 1 <= R,C <= 5000. The second line contains the single integer N, the number of flattened rice plants, 3 <= N <= 5000. Each of the remaining N lines contains two integers, the row number (1 <= row number <= R) and the column number (1 <= column number <= C) of a flattened rice plant, separated by one blank. Each flattened plant is only listed once.

Output

Your program is to write to standard output. The output contains one line with a single integer, the number of plants flattened along a frog path which did the most damage if there exists at least one frog path, otherwise, 0.

Sample Input

6 7
14
2 1
6 6
4 2
2 5
2 6
2 7
3 4
6 1
6 2
2 3
6 3
6 4
6 5
6 7

Sample Output

7
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 5008
int R,C,n;
struct PLANT
{
	int x,y;
}plants[maxn],plant;
int myCompare(const void*a,const void *b)
{
	PLANT *p1,*p2;
	p1 = (PLANT*)a;
	p2 = (PLANT*)b;
	if(p1->x == p2->x)	return (p1->y - p2->y);
	return (p1->x - p2->x);
}
inline int max(int a,int b)
{
	return a>b?a:b;
}
int countpath(PLANT  p,int dX,int dY)
{
	int step = 0;
	while(p.x <= R && p.x >= 1 && p.y >= 1 && p.y <= C)
	{
		if(!bsearch(&p,plants,n,sizeof(PLANT),myCompare))
		{
			step = 0;
			break;
		}
		p.x += dX;	p.y += dY;
		step++;
	}
	return step;
}
int main()
{
	//freopen("in.txt","r",stdin);
	while(scanf("%d%d",&R,&C)==2)
	{
		scanf("%d",&n);
		for(int i = 0;i < n;i++)
		{
			scanf("%d%d",&plants[i].x,&plants[i].y);
		}
		qsort(plants,n,sizeof(PLANT),myCompare);
		int ans = 2;
		for(int i = 0;i < n-2;i++)
		{
			for(int j  = i+1;j < n-1;j++)
			{
				int dX = plants[j].x - plants[i].x;
				int dY = plants[j].y - plants[i].y;
				//剪枝一,如果起点在田地里。跳过
				int pX = plants[i].x - dX;
				int pY = plants[i].y - dY;
				if(pX >= 1 && pX <= R && pY >= 1 && pY <= C)	continue;
				if(pX + ans*dX > R ||	pX + ans*dX < 1)	break;
				if(pY + ans*dY > C ||		pY + ans*dY < 1)	continue;
				int step = countpath(plants[i],dX,dY);
				ans = max(ans,step);
			}
		}
		if(ans == 2)	ans -= 2;
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值