Common Subsequence 动态规划I

roblem Description


A subsequence of a given sequence is the given sequence with some elements (possible none) left

out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of 

X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, 

xij = zj.For example, Z = <a, b, f, c> is a subsequenceof X = <a, b, c, f, b, c> with index sequence<1, 2,

 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common 

subsequence of X and Y. The program input is from a text file. Each data set in the file contains two 

strings representing the given sequences. The sequences are separated by any number of white spaces.

The input data are correct. For each set of data the program prints on the standard output the length of the

 maximum-length common subsequence from the beginning of a separate line. 

 


Sample Input
abcfbc abfcab
programming contest 
abcd mnp
 


Sample Output
4
2
0
 


Source
Southeastern Europe 2003
 


Recommend

Ignatius


题意:对于母串X=<x1,x2,......,xm>, Y=<y1,y2,......,yn>,求最长公共子串。


思路:用二维数组dp[i][j]记录串x1x2......xi与y1y2......yj的能得到最长公共子串,则可得到状态转移方程
          当a[i] == a[j] 时 dp[i][j] = dp[i-1][j-1] + 1;
          否则 dp[i][j] = max(dp[i][j-1],dp[i-1][j]);


#include<iostream>
#include<cstring>
#include<string.h>
#include<algorithm>//max()的函数
const int N = 1000 + 24;
char a[N], b[N];
int dp[N][N];
using namespace std;
int main()
{
#ifdef CDZSC_OFFLINE;
freopen("in.txt", "r", "stbin");
#endif;
while (scanf("%s %s", a + 1, b + 1) != EOF)//注意此处输入前是%s,当输入字符串数组时前为%s,a+1,b+1 表示输入的数组从第二项(1)开始标志,是为了下面从1开始循环方便
{
int i, j;
memset(dp, 0, sizeof(dp));
int len1 = strlen(a + 1);//计算字符串的长度
int len2 = strlen(b + 1);
for (i = 1; i <= len1; i++)//此处的思想是将数组a中的每个元素逐次和数组b比较
for (j = 1; j <= len2; j++)
{
if (a[i] == b[j])//如果a中的第i个元素等于b中的第j个元素
dp[i][j] = dp[i - 1][j - 1] + 1;//dp[i][j]左上方那个数+1,然后动态转移
else
dp[i][j] = max(dp[i][j-1], dp[i - 1][j]);//选出dp[i][j]左侧或者上面最大的那个值动态转移
}
printf("%d\n", dp[len1][len2]);//数组二维数组最后一个元素的值
}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值