每天写一道算法题(4)-Spell It Right

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

PAT的痛点就在英语太差,唉,这道题思路很明了,自然方法也有很多。

#include<iostream>
#include<vector>
#include<string>

using namespace std;


int main(){
	string nums;
	string str[10] = { "zero", "one", "two", "three", "four",
		"five", "six", "seven", "eight", "nine" };
	vector<string> v;
	string eng_str;
	int sum = 0;

	cin >> nums;
	for (int i = 0; i < nums.size(); i++)
		sum += (int)(nums[i] - '0');

	eng_str=to_string(sum);
	for (int i = 0; i < eng_str.size()-1; i++)
		cout << str[eng_str[i] - '0'] << ' ';
	cout << str[eng_str[eng_str.size() - 1] - '0'] << endl;
	return 0;
}

以后。。。简单题就不写了,权当练手了,还是当成总结类型的记录博客来写好了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值