a1002. A+B for Polynomials (25)



This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
 
题意:就是普通二项式相加,因为输入的顺序已确定,从大到小,利用two pointers 很好解决,刚开始没考虑到相加为0的情况,有几个点没过。
 
ac代码:
#include <iostream>
#include <cstdio>
using namespace std;

struct Poly{
	float expo;
	double coef;	
}a[12],b[12],ans[12];

int main(){
//	freopen("D:\input.txt","r",stdin);
	int k1,k2;
	cin>>k1;
	for(int i=0;i<k1;i++){
		cin>>a[i].expo>>a[i].coef;
	}
	
	cin>>k2;
	
	for(int i=0;i<k2;i++){
		cin>>b[i].expo>>b[i].coef;
	}
	
	int cnt=0,i=0,j=0;
	for(;i<k1&&j<k2;){
		if(a[i].expo==b[j].expo){   //相同项合并 
			if(a[i].coef+b[j].coef!=0){
			ans[cnt].expo=a[i].expo;
			ans[cnt].coef=a[i].coef+b[j].coef;
			++cnt; 
			}
			++i; ++j;
		}
		else if(a[i].expo>b[j].expo){
			ans[cnt].expo=a[i].expo;
			ans[cnt].coef=a[i].coef;
			++cnt; ++i;
		}
		else {
			ans[cnt].expo=b[j].expo;
			ans[cnt].coef=b[j].coef;
			++cnt; ++j;
		}
	}
	
	while(i<k1){
		ans[cnt].expo=a[i].expo;
		ans[cnt].coef=a[i].coef;
		++cnt; ++i;
	}
	while(j<k2){
		ans[cnt].expo=b[j].expo;
		ans[cnt].coef=b[j].coef;
		++cnt; ++j;	
	}
	
	cout<<cnt;
	for(int i=0;i<cnt;i++){
	//	cout<<" "<<ans[i].expo<<" "<<ans[i].coef;
		printf(" %1.f %.1f",ans[i].expo,ans[i].coef);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值