1010. Radix (25)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
 
 
题意:这题坑点挺多的,
 
 
1.进制的最大与最小,最小是出现过的数位加1,最大是另一个数(因为此题求进制的最小数)。
2.判定了最大值时,知道要用二分法。
2是最终的乘积可能超过long long型,这时应该在通过进制转为10进制数时的每一步都判断有没有溢出(小于0),
同时如果算的过程中已经大于另一个数了,已经可以跳出这次计算了。
 
 
AC代码:
#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
long long  inf=((long long)1<<63)-1;


long long strtoint(string str,long long radix,long long t){
	long long ans=0;
	for(int i=0;i<str.size();i++){
		int digit;
		if(str[i]>='0'&&str[i]<='9'){
			digit=str[i]-'0';
		}
		else{
			digit=str[i]-'a'+10;
		}

		ans=ans*radix+digit;
		if(ans<0||ans>t) return -1;
	}
	return ans;
}

int main(){
	string s1,s2;
	long long num1;
	int flag;
	long long radix;
	//freopen("E:\input.txt","r",stdin);
	cin>>s1>>s2>>flag>>radix;

    
	if(flag==2) {
		string temp=s1;
  		s1=s2;
  		s2=temp;
	}
 

   num1=strtoint(s1,radix,inf);
   if(strtoint(s2,2,inf)==num1+1) {cout<<2; return 0;}
   
   
    long long l=0,r,mid=-1,ans=num1; 
	bool f=false;
	for(int i=0;i<s2.size();i++){
		int digit;
		if(s2[i]>='0'&&s2[i]<='9'){
			digit=s2[i]-'0';
		}
		else{
			digit=s2[i]-'a'+10;
		}
		if(digit>l) l=digit;
 		}
 		l=l+1;
 		r=max(l,num1);
 	//	printf("l:%lld r:%lld\n",l,r);

    while(l<=r){
    	mid=(l+r)/2;
    		//printf("%lld  mid:%d\n",strtoint(s2,mid,num1),mid);
    	if(strtoint(s2,mid,num1)==num1) {
	    f=true; break; }
    	else if(strtoint(s2,mid,num1)==-1) r=mid-1;
    	else l=mid+1;
    }
    
    if(f==true) cout<<mid;
    else cout<<"Impossible";
    
	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值