1117. Eddington Number(25)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (<=N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N(<=105), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:
10
6 7 6 9 3 10 8 2 7 8
Sample Output:

6


题意:三个E  。最大的E满足有E天大于E公里数这个条件的。 先将数组按小到大排序   从大到小更方便,


ac代码:

#include <iostream>
#include <map>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;

int num[100005];
int main(){

	//freopen("E:\input.txt","r",stdin);
	int n;
	cin>>n;
	for(int i=0;i<n;i++) scanf("%d",&num[i]);

	sort(num,num+n);
	//for(int i=0;i<n;i++) printf("%d ",num[i]);
	//cout<<endl;
	int ans=num[0]-1;

	for(int i=0;i<n;){
		//if(num[i+1]==num[i]) i++;
		//else{
			if(n-i>=num[i]-1) {//printf("i:%d ans:%d cnt:%d\n",i,num[i]-1,n-i);  
				ans=num[i]-1;    if(i<n-1) while(num[i+1]==num[i]) {i++;  if(i>=n-1) break;}   
			i++;}
			else break;
		//}
	}


	cout<<ans;//<<endl;
		freopen("CON","r",stdin);
		system("pause");
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值