【POJ 1276】Cash Machine(多重背包)

 

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31179 Accepted: 11211

 

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

 



题意:给你一个容量为cash的背包和n组价值为d[i]最大数量为n[i]的物品,问最大能凑成的价值为多少。

思路:典型的多重背包,代码进行了二进制优化。


PS:二进制优化是一种将多重背包转化成01背包方法的优化,可以理解成把n件价值为w的物品,分成若干种不同价值的物品。例如:一共有13件价值为w的物品,可以分解成1件价值为w,1件价值为2*w,1件价值为4*w,1件价值为6*w的物品,这样就可以表示出取0种物品到13种物品的所有情况,由此转化成的01背包会比13件价值w的物品更快,算法更为优化。


代码:

#include <cstdio>
#include <iostream>
#include <map>
#include <cstring>
#include <vector>
#define MAXN 100010
using namespace std;
int dp[MAXN],a[2000][2],f[30000];
int main() {
    int cash, n;
    while (~scanf("%d%d", &cash, &n)) {
        int cnt=0;
        for (int i = 0; i < n; i++) {
            scanf("%d%d",&a[i][0],&a[i][1]);
            if(a[i][0]==0||a[i][1]==0)
                continue;
            int k=1;
            while(a[i][0]>k){
                f[cnt++]=k*a[i][1];
                a[i][0]-=k;
                k=k<<1;
            }
            f[cnt++]=a[i][0]*a[i][1];
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<cnt;i++)
            for(int j=cash;j>=f[i];j--)
                dp[j]=max(dp[j-f[i]]+f[i],dp[j]);
        printf("%d\n",dp[cash]);
    }
}



 

转载于:https://www.cnblogs.com/Torrance/p/5410560.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值