POJ 1276 Cash Machine (多重背包+技巧)【标记式背包】

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 
Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

 【题解】

 凑钱数,用给定的钞票所能凑出的不超过m的最大值。

 分析:

 本来这题就是一个简单的多重背包问题,但是!!!我就天真的写了,结果TLE了,我一算,超1e8了能不爆吗,,又开始优化,看见别人用这种标记法优化,我突然惊醒,太妙了,这才叫对症下药啊,为什么这道题能这么做呢,我们想想,这题的本意是看能不能凑出最接近给定值的钱数,而普通的多重背包算法可能会把一个值通过不同的组合出现多次,而这些在这道题中是多余的,只要它出现一次,那我们就已经知道这个值是可以通过组合得到的,所以剩下的那些就成了多余的了,所以在这里我们对症下药,把通过组合出现过的数标记了,只对没出现过的值进行组合,这样就可以降低很多复杂度,而同时只要记录一下出现过的数的最大值就是答案。


【AC代码】

 

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=100005;
int dp[N];
int m,n;
struct money
{
    int num;
    int prices;
}money[12];

int main()
{
     while(~scanf("%d%d",&m,&n))
     {
         for(int i=1;i<=n;++i)
            scanf("%d%d",&money[i].num,&money[i].prices);
         if(!m) {printf("0\n"); continue;}
         if(!n) {printf("0\n"); continue;}
         memset(dp,0,sizeof(dp));
         dp[0]=1;
         int maxn=0;
         for(int i=1;i<=n;++i)
         {
            for(int j=m;j>=0;--j)
            {
                if(dp[j])
                {
                  for(int k=1;k<=money[i].num;++k)
                  {
                    int ss=j+k*money[i].prices;
                    if(ss>m) continue;
                    dp[ss]=1;

                    if(ss>maxn)
                        maxn=ss;
                  }
                }
            }
         }
         printf("%d\n",maxn);
     }
     return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值