【POJ 1936】All in All(字符串处理)

 

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 30743 Accepted: 12827

 

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

 



题意:给你两个字符串,问第一个字符串是否是第二个字符串的可非连续子串。

思路:利用map对于字母和数字的一一对应关系,对串一的每个字母的出现顺序进行对应,如果存在某个字母有多个顺序,就加入vector的尾部。查询时如果发现顺序匹配,就将vector首的元素删除,继续查找,最终如果串一与串二的id相等,即输出yes。


代码:

#include <cstdio>
#include <iostream>
#include <map>
#include <cstring>
#include <vector>
#define MAXN 100010
using namespace std;
map<char, vector<int> >m;
char s[MAXN], t[MAXN];
int main() {
    while (~scanf("%s%s", s, t)) {
        m.clear();
        int lens = strlen(s), lent = strlen(t);
        int id_before = 1;
        for (int i = 0; i < lens; i++) {
            if (!m.count(s[i]))
                m[s[i]] = vector<int>();
            m[s[i]].push_back(id_before++);
        }
        int id_after = 1;
        for (int i = 0; i < lent; i++) {
            if (!m[t[i]].size())
                continue;
            else if (m[t[i]].front() == id_after) {
                id_after++;
                m[t[i]].erase(m[t[i]].begin());
            }
        }
        if (id_before != id_after)
            printf("No\n");
        else printf("Yes\n");
    }
}




 

转载于:https://www.cnblogs.com/Torrance/p/5410561.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值