POJ-1936 All in All(字符串另类解法)

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 34444 Accepted: 14396

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

Ulm Local 2002

题目大意是给出两个字符串,判断第一个字符串里所有的字母在第二个字符串里是不是都含有,可以不连续,但是顺序不能乱。

这个时候可以使用特殊的方式解决

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

char a[100002],b[100005];
int main()
{
	while(~scanf("%s%s",a,b))
	{
		int len1 = strlen(a);
		int len2 = strlen(b);
		int x = 0, y = 0;
		for(int i = 0;;i++)
		{
			if(a[x] == b[i])
			{
				y++;//统计一二字符串里相同的字母数
				x++;//更新第一个字符串的下一个字母
			}
			if(i == len2 -1)
			break;
		}
		if(y == len1)
		cout << "Yes" <<endl;
		else
		cout << "No" <<endl;
	}
	return 0;
}

这个小技巧在贪心的字典序也用的到。x++更新字符

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值