PAT (Advanced Level) Practice 1046

1046 Shortest Distance (20)(20 point(s))

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 10^5^]), followed by N integer distances D~1~ D~2~ ... D~N~, where D~i~ is the distance between the i-th and the (i+1)-st exits, and D~N~ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=10^4^), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7^.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
题意:第一行第一个整数n(n∈[3,10^5])表示有n个点,后面n个整数分别为i到i+1之间的距离,形成一个环,即最后一个整数为点n到点1的距离。请问从一个点到另一个点之间最短距离是多少。

思路:sum[i]数组,表示从第1个点到第i个点之间的和为多少。这样,1到任意一个点的距离和就能求出来,这样通过sum[j]-sum[i]就能求出i到j之间的距离。

代码:

#include<cstdio>
int sum[50010];
int main(){
	
	int total = 0, N;
	scanf("%d", &N);
	for(int i = 0;i < N;i++){
		int v;
		scanf("%d", &v);
		total += v;
		sum[i + 1] = total;//存储1 ~ i 之间的整数和 
	}
	
	int M;
	scanf("%d", &M);
	for(int i = 0;i < M;i++){
		int a, b;
		scanf("%d%d", &a, &b);
		if(a > b){
			int t = a;
			a = b;
			b = t;
		}
		int sumA = total - (sum[a-1] + total - sum[b - 1]);
		int sumB = total - sumA;
		printf("%d\n", sumA > sumB ? sumB : sumA);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值