【PAT】A1078 Hashing【hash】

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10^​4​​ ) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题意

给出一个待定的TSize和一个hash插入序列,求使用最小的大于等于TSize的素数值作为hash的TSize,求这个插入序列中各个元素在hash表中的下标(使用二次平方探测),散列函数为H(key) = key % TSize。

思路

按照题意书写即可。素数判定的时候,注意对小于等于1的数进行特判。

代码

#include <cstdio>
#include <cmath>
#include <cstring>
#define MAX_N 11111
bool isPrime(int n){
    if(n <= 1) return false;// 注意小于等于1不是素数
    for(int i = 2, l = sqrt(n); i <= l; i++){
        if(n % i == 0)return false;
    }
    return true;
}
bool hashTable[MAX_N];
int TSize;
// 返回元素的hash下标,不能插入返回-1
int hash(int n){
    int M = n % TSize;
    if(!hashTable[M]){
        hashTable[M] = true;
        return M;
    }else{// 二次平方探测
        int step = 1;
        while (step < TSize) {
            M = (n + step * step) % TSize;
            if(!hashTable[M]){
                hashTable[M] = true;
                return M;
            }
            step++;
        }
        
        // 无法插入
        return -1;
    }
}
int main() {
    memset(hashTable, 0, sizeof(bool));
    int N;
    scanf("%d %d", &TSize, &N);
    while (!isPrime(TSize)) TSize++;// 找到第一个大于等于TSize的素数
    for(int i = 0, t; i < N; i++){
        scanf("%d", &t);
        t = hash(t);
        
        
        if(i > 0) putchar(' ');// 处理空格
        
        // 输出
        if(t == -1){
            putchar('-');
        }else{
            printf("%d", t);
        }
        
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值