【PAT】A1148 Werewolf - Simple Version

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

player #1 said: “Player #2 is a werewolf.”;
player #2 said: “Player #3 is a human.”;
player #3 said: “Player #4 is a werewolf.”;
player #4 said: “Player #5 is a human.”; and
player #5 said: “Player #4 is a human.”.
Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

题意

给出一组人的发言,第i个人的发言正数a代表他说第a个人是人,负数代表狼人。现在假设一场游戏中有两个狼人,且只有一个狼人说谎,总共有两人说谎。求两个狼人分别是是谁。

思路

将所有人的发言存起来,然后遍历两个狼人,O(N2)级别算法。

代码

#include <cstring>
#include <iostream>
#define MAX_N 101
int word[MAX_N], N;
bool solve(int& i, int& j){
    int cnt, wcnt;
    for(i = 1; i <= N; i++){
        for(j = i + 1; j <= N; j++){
            cnt = 0, wcnt = 0;
            for(int k = 1; k <= N; k++){
                if(word[k] == i || word[k] == j || (word[k] < 0 && -word[k] != i && -word[k] != j)) {
                    cnt++;
                    if(k == i || k == j) wcnt++;// 它是狼人,则累计狼人说谎
                }
            }
            if(cnt == 2 && wcnt == 1) return true;
        }
    }
    return false;
}
int main() {
    
    scanf("%d", &N);
    for(int i = 1; i <= N; i++) scanf("%d", word + i);
    int i, j;
    if(solve(i, j))printf("%d %d", i, j);
    else printf("No Solution");
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值