Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
题目大意
有n个考场,每个考场有若干数量的学生,给出每个考场中考生的编号和分数,要求算排名,输出所有考生的编号、排名、考场号、考场内排名。
思路
分别对学生在考场内排名,以及总成绩排名。两次排序即可。注意成绩相同的考生并列排名。具体细节看代码。
代码
#include <iostream>
#include <vector>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Student{
long long code;
int grade;
int local;
int localRank;
int finalRank;
};
bool cmp(Student s1, Student s2){
return s1.grade != s2.grade ? s1.grade > s2.grade : s1.code < s2.code;
}
int main() {
int n, k;
scanf("%d", &n);
vector<Student> f;
// 对于每个考场
for(int i = 1; i <= n; i++){
scanf("%d", &k);
vector<Student> v(k);
// 读取该考场内所有的考生
for(int j = 0; j < k; j++){
scanf("%lld %d", &v[j].code, &v[j].grade);
v[j].local = i;
}
// 排序
sort(v.begin(), v.end(), cmp);
// 计算考生在考场内的排名,并将其加入f向量中
v[0].localRank = 1;
f.push_back(v[0]);
for(int j = 1; j < k; j++){
v[j].localRank = v[j].grade == v[j - 1].grade ? v[j - 1].localRank : j + 1;
f.push_back(v[j]);
}
}
// 最后对f向量排序,计算总排名
sort(f.begin(), f.end(), cmp);
f[0].finalRank = 1;
const long size = f.size();
for(int j = 1; j < size; j++){
f[j].finalRank = f[j].grade == f[j - 1].grade ? f[j - 1].finalRank : j + 1;
}
printf("%ld\n", f.size());
// 输出结果
for(auto lt = f.cbegin(); lt != f.cend(); lt++){
printf("%013lld %d %d %d\n", lt->code, lt->finalRank, lt->local, lt->localRank);
}
return 0;
}