【PAT】A1071 Speech Patterns【字符串处理】

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: “Can a can can a can? It can!”

Sample Output:

can 5

题意

求一个句子中出现次数最多的单词和它的出现次数。对有效字符(0-9a-zA-Z)以外的字符都作为单词的分隔符。

思路

这题和A1054几乎一样,这是增加了处理输入的难度。由于stl中没有split函数,所以我们只能遍历输入的字符串,如果是有效字符,则加入一个临时变量word中,每得到一个完整的word,就使用map存储它的计数(初始化为0或者加1)。具体细节看代码。

代码

#include <iostream>
#include <string>
#include <map>
#include <cctype>
using namespace std;
int main() {
    string s, word;
    map<string, int> cnt;
    getline(cin, s);
    
    
    for(int i = 0, l = s.length(); i < l; i++){
        word.clear();
        // 如果字符是有效字符,则加入临时变量word中
        while (i < l && isalnum(s[i])) {
            word.push_back(tolower(s[i]));
            i++;
        }
        
        // 如果单词为空,则进入下一轮循环
        if(word.length() == 0) continue;
        
        // 找不到该单词的计数,则初始化为1, 否则累加
        if(cnt.find(word) == cnt.cend()){
            cnt[word] = 1;
        }else{
            cnt[word]++;
        }
    }
    
    // 遍历求出现次数最多的单词
    string res;
    int maxCnt = -1;
    for(auto lt = cnt.cbegin(); lt != cnt.cend(); lt++){
        if(lt->second > maxCnt){
            maxCnt = lt->second;
            res = lt->first;
        }
    }
    cout << res << " " << maxCnt;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值