【PAT】A1112 Stucked Keyboard【字符串处理】

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

题意

如果一个键坏了,那么点它一次会出现连续的k个字符。现在给出k和一个字符串,求坏键(按出现次序)和原本应该输出的字符串(假设坏键没坏的时候)。

思路

因为字符就256个,我们开三个布尔数组marked、showed、printed分别表示某个键是否为坏键、是否出现、是否被输过。然后顺序遍历两次输入字符串,第一次遍历找出坏键,第二次求结果字符串并顺次输出坏键。
我们分析后得到坏键的规则如下:
如果有一次连续出现(把单独出现一次也看做连续出现)不是k的倍数,则该键一定不是坏键,否则该键可能是坏键。

代码

#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
#define L 256
bool marked[L], showed[L], printed[L];
int main() {
    fill(marked, marked + L, true);
    fill(showed, showed + L, false);
    fill(printed, printed + L, false);
    int k, len;
    char s[1001];
    scanf("%d", &k);
    scanf("%s", s);
    len = (int)strlen(s);
    
    // 遍历得到坏键和显示的键
    vector<int> repeats[L];
    for(int i = 0, j, code; i < len;){
        j = i + 1;
        code = s[i];
        while (j < len && s[j] == s[j - 1])j++;
        if((j - i) % k != 0) marked[code] = false;// 如果有一次连续出现(把单独出现一次也看做连续出现)不是k的倍数,则该键一定不是坏键
        showed[code] = true;// 标记该键出现过
        i = j;
    }
    
    
    // 边遍历得到结果字符串r边输出坏键
    char r[1001];
    int rlen = 0;
    for(int i = 0, code; i < len;){
        code = s[i];
        r[rlen++] = code;
        if(marked[code]){
            i += k;
            if(!printed[code]){
                putchar(code);
                printed[code] = true;
            }
        }else{
            i++;
        }
    }
    r[rlen] = '\0';
    
    printf("\n%s", r);
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值