【PAT】A1040 Longest Symmetric String【最长回文子串】

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

题意

求最长回文串的长度。

思路

动态规划写法。具体总结待整理//TODO大法。
要注意fgets需要读取到换行符,所以fgets的最大长度需要比一行的字符数多1,否则读取不到换行符会出错。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 1000
using namespace std;
char s[MAX_N + 1];
int dp[MAX_N][MAX_N];
int main() {
    fgets(s, MAX_N + 1, stdin);
    int len = (int)strlen(s), res = 1;
    // 边界
    for(int i = 0; i < len; i++){
        dp[i][i] = 1;
        if(i < len - 1 && s[i] == s[i + 1]){
            dp[i][i + 1] = 1;
            res = 2;
        }
    }
    
    // 遍历L从3到len
    for(int L = 3; L <= len; L++){
        for(int i = 0, l = len - L + 1, j; i < l; i++){
            j = i + L - 1;
            if(s[i] == s[j] && dp[i + 1][j - 1] == 1){
                dp[i][j] = 1;
                res = L;
            }
        }
    }
    printf("%d", res);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值