Pick Game

Problem Description

  One day, hh plays a game with GL. On a n*m matrix, each gird has a value. The player could only choose the gird that is adjacent to at least two empty girds (A grid outside the matrix also regard as empty). Adjacent means two girds share a common edge. If one play chooses one gird, he will get the value and the gird will be empty. They play in turn.
  GL and hh are clever boys. They will choose the best strategy, hh plays first, and he wants to know the maximal value he could get.

Input

On the first line of input is a single positive integer, 1<=T<=50, specifying the number of test cases to follow.
Each test case begins with two numbers n and m. (2<=n, m<=5)
Then n lines follow and each lines with m numbers Vij. (0< Vij <=1000)

Output

Output the maximal value hh could get.

Sample Input

1
2 2
9 8
7 6

Sample Output

16

Source

2014-03-PK2


题意:n*m的矩阵,2个人轮流取一个格子的值,要求取的格子四周至少有2个空的格子,hh先取,求他能取得的最大值

分析:记忆化搜索,dp表示当前状态hh比GL多的值,0表示这一个未取,1表示已取,一共最多有2^25种状态,用hash散列来存



#include <iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#define mod 10007
#define N 10010
#include<vector>
using namespace std;
vector<int> v[N],dp[N];
int n,m,cnt,Map[6][6];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
bool ok(int x,int y){
    if(x<n&&x>=0&&y<m&&y>=0)
    return true;
    return false;
}
int Gets(int st){
    int ret=0;
    for(int i=0;i<cnt;i++){
        if(((1<<i)&st)==0){
            ret+=Map[i/m][i%m];
        }
    }
    return ret;
}
int cal(int st){
    int ret=0,i;
    for(i=0;i<cnt;i++)
    if((1<<i)&st)
    ret++;
    return ret;
}
int dfs(int st){
    int next,ans,i,j,tmp,x,y,xx,yy;
    x=st%mod;
    for(y=v[x].size()-1;y>=0;y--){
        if(v[x][y]==st)
        return dp[x][y];
    }
    if(cal(st)==cnt-1)
    return Gets(st);
    ans=-20006;
    for(i=0;i<cnt;i++){
        if(((1<<i)&st)==0){
            x=i/m;
            y=i%m;
            tmp=0;
            for(j=0;j<4;j++){
                xx=x+dir[j][0];
                yy=y+dir[j][1];
                if(!ok(xx,yy)||(ok(xx,yy)&&(((1<<(xx*m+yy))&st)))){
                    tmp++;
                }
            }
            if(tmp>=2){
                next=(1<<i) | st;
                ans=max(ans,Map[x][y]-dfs(next));
            }
        }
    }
    v[st%mod].push_back(st);
    dp[st%mod].push_back(ans);
    return ans;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--){
        for(i=0;i<mod;i++){
            dp[i].clear();
            v[i].clear();
        }
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++){
            for(j=0;j<m;j++){
                scanf("%d",&Map[i][j]);
            }
        }
        cnt=n*m;
        printf("%d\n",(dfs(0)+Gets(0))/2);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值