appcompat_v7/res/values-v21/themes_base.xml No resource found that matches the given name

转:

将工作区里的appcompat_v7删除掉了, 然后随意新建了一个工程,因为已经升级到5.0了,appcompat_v7内容有所改变,

以前的工程引用旧的appcompat_v7的某些属性在新的里面找不到,就都报错了


捣腾了两小时,解决方法如下:

project.properties中target=android-21   意思是必须是5.0来编译

新建一个min-sdk小于14的工程A,会有appcompat_v7生成

将A中的对应values目录下的style的内容,相应的复制到 原有工程的style里面

再clean一下,基本解决。

如果某些没用到的系统style依然报错,删除它

如果某些引用的系统的图片、color什么的没有,就换一个,或者删除掉


建议:用自己常用appcompat_v7搭配的工程,删除新建工程里面报错的xml里的属性

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页