快速幂+快速乘

Given abc find the value of ab mod c (1 ≤ abc < 263).

Input

Contains multiple test cases. Each test is given in one line and contains three integers ab and c.

Output

For each test case print on a separate line the value of ab mod c.

Example 1

Input example #1
3 2 4
2 10 1000
Output example #1
1
24
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<cmath>
#include<string>
#include<map>
#include<queue>
using namespace std;
typedef unsigned long long ll;
ll a;
ll b,c;

ll mm(ll a,ll b){
	ll sum=0;
	while(b){
		if(b&1){
			sum=(sum+a)%c;
		}
		b>>=1;
		a=(a+a)%c;
	}
	return sum;
}

int main(){
	while(~scanf("%lld %lld %lld",&a,&b,&c)){
		ll sum=1;
		a=(ll)a%c;
		while(b>0){
			if(b&1)
			sum=(mm(sum,a))%c;
			b>>=1;
			a=(mm(a,a))%c;
		}
		printf("%lld\n",sum);
	}
	return 0;
}

  

转载于:https://www.cnblogs.com/akpower/p/11325728.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值