hdoj 2680 最短路(dijkstra)

Choose the best route



Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

Author
dandelion
 

Source
  找了2小时的错,最后我发现

路是单向的!!!
牢记教训!!!
起点不确定,终点确定,所以我们可以把终点当成起点,反着进行寻路过程,反正一样的- -,这样只要进行一次dijkstra就行
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
const int MAX=1010;
int dist[MAX],n,map[MAX][MAX],vis[MAX];
void Dijkstra(int s)
{
    int i,j,min,pos;
    memset(vis,0,sizeof(vis));
    for(i=1;i<=n;i++)
        dist[i]=map[s][i];
    dist[s]=0;
    vis[s]=1;
    for(i=1;i<=n;i++)
    {
        min=INF;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&dist[j]<min)
                min=dist[pos=j];
        }
        if(min==INF)
            break;
        vis[pos]=1;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&dist[pos]+map[pos][j]<dist[j])
                dist[j]=dist[pos]+map[pos][j];
        }
    }
}
int main()
{
    int i,e,a,b,c,x,y,m;
    while(scanf("%d%d%d",&n,&m,&e)!=EOF)
    {
        memset(map,INF,sizeof(map));
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(c<map[b][a])
                map[b][a]=c;
        }
        Dijkstra(e);
        scanf("%d",&x);
        int ans=INF;
        while(x--)
        {
            scanf("%d",&y);
            if(dist[y]<ans)
                ans=dist[y];
        }
        if(ans!=INF)
            printf("%d\n",ans);
        else
            printf("-1\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值