POJ 2141 Message Decowding

C - Message Decowding
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:
        yrwhsoujgcxqbativndfezmlpk

Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

Input

* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded

Output

* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

Sample Input

eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj

Sample Output

Jump the fence when you seeing me coming

#include <iostream>
#include<cstdio>
#include<string.h>

using namespace std;
int main()
{
    char a[30],b[81];
    cin>>a;//好像不能用gets(a);
    char c;
    getchar();//也是不能省略
    gets(b);//可以输入空格
    int len=strlen(b);
    for(int i=0; i<len; i++)
    {
        if(isalpha(b[i]))//判断是否是字母
        {
            if(isupper(b[i]))//判断是否是大写字母
                cout<<(c=a[b[i]-'A']-'a'+'A');
            else cout<<a[b[i]-'a'];
        }
        else printf("%c",b[i]);
        //else  putchar(b[i]);用上面的也可以
    }
    return 0;
}
学习总结:

给你一个26个字符的字符串A,相当于从a到z或对应的从A到Z的加密,让你将字符串B按照A的加密方式进行加密

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值