省赛一Ballons dfs

Balloons

Time Limit: 1000MS Memory limit: 65536K

题目描述

Both Saya and Kudo like balloons. One day, they heard that in the central park, there will be thousands of people fly balloons to pattern a big image.
They were very interested about this event, and also curious about the image.
Since there are too many balloons, it is very hard for them to compute anything they need. Can you help them?
You can assume that the image is an N*N matrix, while each element can be either balloons or blank.
Suppose element A and element B are both balloons. They are connected if:
i) They are adjacent;
ii) There is a list of element C1, C2, … , Cn, while A and C1 are connected, C1 and C2 are connected …Cn and B are connected.
And a connected block means that every pair of elements in the block is connected, while any element in the block is not connected with any element out of the block.
To Saya, element A(xa,ya)and B(xb,yb) is adjacent if |xa-xb| + |ya-yb| 1
But to Kudo, element A(xa,ya) and element B (xb,yb) is adjacent if |xa-xb|≤1 and |ya-yb|1
They want to know that there’s how many connected blocks with there own definition of adjacent?

输入

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N100), which represents the size of the matrix.
Each of the next N lines contains a string whose length is N, represents the elements of the matrix. The string only consists of 0 and 1, while 0 represents a block and 1represents balloons.
The last case is followed by a line containing one zero.

输出

For each case, print the case number (1, 2 …) and the connected block’s numbers with Saya and Kudo’s definition. Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

5
11001
00100
11111
11010
10010

0

示例输出

Case 1: 3 2
#include <iostream>
#include<string.h>
#include<cstdio>
using namespace std;
char map[101][101];
int vis[101][101];
int n;
void dfs1(int x,int y)///仅仅4个方向
{
    if(map[x][y]=='0'||x<0||x>=n||y<0||y>=n||vis[x][y])
        return;
    vis[x][y]=1;
    dfs1(x+1,y);
    dfs1(x-1,y);
    dfs1(x,y+1);
    dfs1(x,y-1);
}
void dfs2(int x,int y)
{
    if(map[x][y]=='0'||x<0||y<0||x>=n||y>=n||vis[x][y])
        return;
    vis[x][y]=1;
    dfs2(x+1,y);
    dfs2(x,y+1);
    dfs2(x-1,y);
    dfs2(x,y-1);
    dfs2(x+1,y+1);
    dfs2(x-1,y-1);
    dfs2(x+1,y-1);
    dfs2(x-1,y+1);
}
int main()
{
    while(scanf("%d",&n)&&n)
    {
        int j=0;
        int sum1=0;
        int sum2=0;
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
            scanf("%s",map[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                if(!vis[i][j]&&map[i][j]=='1')///vis[x][y]==0&&map[x][y]=='1'
                {
                    dfs1(i,j);
                    sum1++;
                }
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                if(!vis[i][j]&&map[i][j]=='1')
                {
                    dfs2(i,j);
                    sum2++;
                }
        printf("Case %d: %d %d\n\n",++j,sum1,sum2);
    }
    return 0;
}

总结:做了这一个题,类似的深搜都理解了
此题关键理解:
To Saya, element A(xa,ya)and B(xb,yb) is adjacent if |xa-xb| + |ya-yb|  1 ///4个方向
But to Kudo, element A(xa,ya) and element B (xb,yb) is adjacent if |xa-xb|≤1 and |ya-yb|1///8个方向

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值