HDU5233

Gunner II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1244    Accepted Submission(s): 486

Problem Description
Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the nearest bird which stands in the tree with height H will falls.
Jack will shot many times, he wants to know which bird will fall during each shot.
 
Input
There are multiple test cases (about 5), every case gives n, m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times. 
In the second line, there are n numbers h[1],h[2],h[3],…,h[n] which describes the height of the trees.
In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.
Please process to the end of file.
[Technical Specification]
All input items are integers.
1<=n,m<=100000(10^5)
1<=h[i],q[i]<=1000000000(10^9)
 
Output
For each q[i], output an integer in a single line indicates the id of bird Jack shots down. If Jack can’t shot any bird, just output -1.
The id starts from 1.
 
Sample Input
5 5
1 2 3 4 1
1 3 1 4 2
 
Sample Output
1
3
5
4

2

//这题主要思路就是利用一个结构体将高度与序号记录下来
//再利用一个数组将高度排序并且标记高度出现的顺序

#include <stdio.h>
#include <algorithm>
using namespace std;
int flag[100010],h[100010];

struct bird
{
    int n,num;
}p[100010];

bool cmp(const bird &a,const bird &b)
{
    return a.n!=b.n?a.n<b.n:a.num<b.num;
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++ )
        {
            scanf("%d",&p[i].n);
            p[i].num=i+1;
        }
        sort(p,p+n,cmp);
        for(int i=0;i<n;i++)
        {
            flag[i]=i;   //此时的flag数组是标记高度第一次出现的位置
            h[i]=p[i].n;
        }
        while(m--)
        {
            int x;
            scanf("%d",&x);
            int q=lower_bound(h,h+n,x)-h;  //查询到的也是第一次出现的次数
            if(h[flag[q]]!=x)
            {
                printf("-1\n");
                continue;
            }
            else
                printf("%d\n",p[flag[q]].num);
            flag[q]++;  //由于查询过一次了 所以递增到下一个高度
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值