HDU 1754

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 52648    Accepted Submission(s): 20685


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
  
  
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
  
  
5 6 5 9
Hint
Huge input,the C function scanf() will work better than cin
 
//线段树单点更新 第一道
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int maxn=200000;
const int inf=(1<<30);
int Max=-inf;
struct Node
{
    int l,r;
    int max_num;
    int mid()
    {
        return (l+r)/2;
    }
}tree[maxn*4];
int arr[maxn];
void Buildtree(int rt,int l,int r)
{
    tree[rt].l=l;
    tree[rt].r=r;
    tree[rt].max_num=-inf;
    if(l==r)
    {
        tree[rt].max_num=arr[l];
    }
    else
    {
        Buildtree(2*rt,l,(l+r)/2);
        Buildtree(2*rt+1,(l+r)/2+1,r);
        tree[rt].max_num=max(tree[2*rt].max_num,tree[2*rt+1].max_num);
    }
}
void Update(int rt,int num,int val)
{
    if(tree[rt].r==tree[rt].l&&tree[rt].l==num)
    {
        tree[rt].max_num=val;
        return;
    }
    if(num<=tree[rt].mid())
        Update(2*rt,num,val);
    else
        Update(2*rt+1,num,val);
    tree[rt].max_num=max(tree[2*rt].max_num,tree[2*rt+1].max_num);
}
void Query(int rt,int l,int r)
{
    if(tree[rt].l==l&&tree[rt].r==r)
    {
        Max=max(tree[rt].max_num,Max);
        return;
    }
    if(r<=tree[rt].mid())
    {
        Query(2*rt,l,r);
    }
    else if(l>tree[rt].mid())
    {
        Query(2*rt+1,l,r);
    }
    else
    {
        Query(2*rt,l,tree[rt].mid());
        Query(2*rt+1,tree[rt].mid()+1,r);
    }
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",arr+i);
        }
        Buildtree(1,1,n);
        for(int i=0;i<m;i++)
        {
            char c;
            getchar();
            scanf("%c",&c);
            if(c=='Q')
            {
                int l,r;
                Max=-inf;
                scanf("%d%d",&l,&r);
                Query(1,l,r);
                printf("%d\n",Max);
            }
            else if(c=='U')
            {
                int num,val;
                scanf("%d%d",&num,&val);
                Update(1,num,val);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值