hdu 5567

18 篇文章 0 订阅

sequence1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 292    Accepted Submission(s): 218


Problem Description
Given an array  a  with length  n , could you tell me how many pairs  (i,j)  ( i < j ) for  abs(aiaj) mod b=c .
 

Input
Several test cases(about  5 )

For each cases, first come 3 integers,  n,b,c(1n100,0c<b109)

Then follows  n  integers  ai(0ai109)
 

Output
For each cases, please output an integer in a line as the answer.
 

Sample Input
  
  
3 3 2 1 2 3 3 3 1 1 2 3
 

Sample Output
  
  
1 2
 
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <map>
#include <queue>
#include <iostream>
using namespace std;
const int maxn=200;
int a[maxn];
int main()
{
    int n,b,c;
    while(~scanf("%d%d%d",&n,&b,&c))
    {
        int cnt=0;
        for(int i=0;i<n;i++)
            scanf("%d",a+i);
        for(int i=0;i<n;i++)
        {
            for(int k=i+1;k<n;k++)
            {
                if(abs(a[k]-a[i])%b==c)
                    cnt++;
            }
        }
        printf("%d\n",cnt);
    }


    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值