GTW likes gt
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 316 Accepted Submission(s): 111
Problem Description
Long long ago, there were
n
adorkable GT. Divided into two groups, they were playing games together, forming a column. The
i−th
GT would randomly get a value of ability
bi
. At the
i−th
second, the
i−th
GT would annihilate GTs who are in front of him, whose group differs from his, and whose value of ability is less than his.
In order to make the game more interesting, GTW, the leader of those GTs, would emit energy for m times, of which the i−th time of emitting energy is ci . After the ci second, b1,b2,...,bci would all be added 1.
GTW wanted to know how many GTs would survive after the n−th second.
In order to make the game more interesting, GTW, the leader of those GTs, would emit energy for m times, of which the i−th time of emitting energy is ci . After the ci second, b1,b2,...,bci would all be added 1.
GTW wanted to know how many GTs would survive after the n−th second.
Input
The first line of the input file contains an integer
T(≤5)
, which indicates the number of test cases.
For each test case, there are n+m+1 lines in the input file.
The first line of each test case contains 2 integers n and m , which indicate the number of GTs and the number of emitting energy, respectively. (1≤n,m≤50000)
In the following n lines, the i−th line contains two integers ai and bi , which indicate the group of the i−th GT and his value of ability, respectively. (0≤ai≤1,1≤bi≤106)
In the following m lines, the i−th line contains an integer ci , which indicates the time of emitting energy for i−th time.
For each test case, there are n+m+1 lines in the input file.
The first line of each test case contains 2 integers n and m , which indicate the number of GTs and the number of emitting energy, respectively. (1≤n,m≤50000)
In the following n lines, the i−th line contains two integers ai and bi , which indicate the group of the i−th GT and his value of ability, respectively. (0≤ai≤1,1≤bi≤106)
In the following m lines, the i−th line contains an integer ci , which indicates the time of emitting energy for i−th time.
Output
There should be exactly
T
lines in the output file.
The i−th line should contain exactly an integer, which indicates the number of GTs who survive.
The i−th line should contain exactly an integer, which indicates the number of GTs who survive.
Sample Input
1 4 3 0 3 1 2 0 3 1 1 1 3 4
Sample Output
3HintAfter the first seconds,$b_1=4,b_2=2,b_3=3,b_4=1$ After the second seconds,$b_1=4,b_2=2,b_3=3,b_4=1$ After the third seconds,$b_1=5,b_2=3,b_3=4,b_4=1$,and the second GT is annihilated by the third one. After the fourth seconds,$b_1=6,b_2=4,b_3=5,b_4=2$ $c_i$ is unordered.
Source
//只能说下次做题的时候看题目的时间千万不能省。。
//先累加完 接着利用multiset 存 type为1 和type为2的两种
//stl 真心强大 寒假回去要好好啃书了。。
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <set>
using namespace std;
int n;
struct Node
{
int flag,val;
}p[50005];
int vis[50005],res[50005];
multiset<int>s1,s2;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int m;
memset(res,0,sizeof(res));
memset(vis,0,sizeof(vis));
s1.clear();
s2.clear();
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++)
scanf("%d%d",&p[i].flag,&p[i].val);
for(int i=1;i<=m;i++)
{
int time;
scanf("%d",&time);
vis[i]=time;
}
sort(vis+1,vis+m+1);
for(int i=1;i<=m;i++)
{
res[1]+=1;
res[vis[i]+1]-=1;
}
int ans=0;
for(int i=1;i<=n;i++)
{
ans+=res[i];
p[i].val+=ans;
}
int an=0;
for(int i=1;i<=n;i++)
{
if(p[i].flag==1)
{
while(!s1.empty())
{
if(*s1.begin()<p[i].val)
{
s1.erase(s1.begin());
an++;
}
else
break;
}
s2.insert(p[i].val);
}
else
{
while(!s2.empty())
{
if(*s2.begin()<p[i].val)
{
s2.erase(s2.begin());
an++;
}
else
break;
}
s1.insert(p[i].val);
}
}
printf("%d\n",n-an);
}
return 0;
}