poj 3260(多重+完全背包)

27 篇文章 0 订阅
The Fewest Coins
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6030 Accepted: 1807

Description

Farmer John has gone to town to buy some farm supplies. Being a very efficient man, he always pays for his goods in such a way that the smallest number of coins changes hands, i.e., the number of coins he uses to pay plus the number of coins he receives in change is minimized. Help him to determine what this minimum number is.

FJ wants to buy T (1 ≤ T ≤ 10,000) cents of supplies. The currency system has N (1 ≤ N ≤ 100) different coins, with values V1V2, ..., VN (1 ≤ Vi ≤ 120). Farmer John is carrying C1 coins of value V1C2 coins of value V2, ...., and CN coins of value VN (0 ≤ Ci ≤ 10,000). The shopkeeper has an unlimited supply of all the coins, and always makes change in the most efficient manner (although Farmer John must be sure to pay in a way that makes it possible to make the correct change).

Input

Line 1: Two space-separated integers:  N and  T
Line 2: N space-separated integers, respectively  V 1V 2, ...,  VN coins ( V 1, ... VN
Line 3: N space-separated integers, respectively  C 1C 2, ...,  CN

Output

Line 1: A line containing a single integer, the minimum number of coins involved in a payment and change-making. If it is impossible for Farmer John to pay and receive exact change, output -1.

Sample Input

3 70
5 25 50
5 2 1

Sample Output

3

Hint

Farmer John pays 75 cents using a 50 cents and a 25 cents coin, and receives a 5 cents coin in change, for a total of 3 coins used in the transaction.

Source

USACO 2006 December Gold


多重背包求解得到数T(此T非题目给的T因为可以找零所以可以大于它)的最小代价 完全背包求解找零后的最小代价 前面T开小了直接wa 一怒之下直接标到200000

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
const int inf=(1<<30);
int a[200];
int num[200];
int dp[210015];
int n,t;

void ZeroOnePack(int w,int v)
{
    for(int i=200000;i>=w;i--)
        if(dp[i-w]+v<dp[i])
            dp[i]=dp[i-w]+v;
}

void CompletePack(int w,int v)
{
    for(int i=w;i<=200000;i++)
         if(dp[i-w]+v<dp[i])
            dp[i]=dp[i-w]+v;
}

void MultiplePack()
{
    for(int i=1;i<=n;i++)
    {
        if(a[i]*num[i]>200000)
            CompletePack(a[i],1);
        else
        {
            int k=1;
            while(k<num[i])
            {
                ZeroOnePack(a[i]*k,k);
                num[i]-=k;
                k*=2;
            }
            ZeroOnePack(a[i]*num[i],num[i]);
        }
    }
}

int main()
{
    while(~scanf("%d%d",&n,&t))
    {
        for(int i=1;i<=210005;i++)
            dp[i]=inf;
        dp[0]=0;
        for(int i=1;i<=n;i++)
            scanf("%d",a+i);
        for(int i=1;i<=n;i++)
            scanf("%d",num+i);
        MultiplePack();  //可以凑到的数
        for(int i=1;i<=n;i++)  //完全背包找零
            for(int k=200000;k>=1;k--)
                 if(dp[k+a[i]]+1<dp[k])
                        dp[k]=dp[k+a[i]]+1;
        if(dp[t]==inf)
            puts("-1");
        else
            printf("%d\n",dp[t]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值