1078

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

Source
 

动态规划,求路径内的最大值。

#include <stdio.h>
#define SIZE 100

int n,k,a[2][SIZE][SIZE];

int f(int cur_i,int cur_j)
{
	int i,max=0,term_i,term_j,sub_v,sub_h;
	sub_v=sub_h=0;
	for (i=-k;i<=k;++i)
	{
		term_i=cur_i+i;//竖着走
		if (term_i>=0 && term_i<n)
		{
			if (a[0][term_i][cur_j]>a[0][cur_i][cur_j])
			{
				if (a[1][term_i][cur_j]==0)
				{
					a[1][term_i][cur_j]=f(term_i,cur_j);//记录当前点的最大值
				}
				
				if (a[1][term_i][cur_j]>sub_v)
				{
					sub_v=a[1][term_i][cur_j];
				}
			}
		}
		term_j=cur_j+i;//横着走
		if (term_j>=0 && term_j<n)
		{
			if (a[0][cur_i][term_j]>a[0][cur_i][cur_j])
			{
				if (a[1][cur_i][term_j]==0)
				{
					a[1][cur_i][term_j]=f(cur_i,term_j);//记录当前点的最大值

				}
				
				if (a[1][cur_i][term_j]>sub_h)
				{
					sub_h=a[1][cur_i][term_j];
				}
			}
		}
	}
	max=sub_v>sub_h?sub_v:sub_h;

	return a[0][cur_i][cur_j]+max;
}

int main()
{
	int i,j;
	while(scanf("%d%d",&n,&k) && n!=-1 && k!=-1)
	{
		for (i=0;i<n;i++)
		{
			for (j=0;j<n;j++)
			{
				scanf("%d",&a[0][i][j]);
				a[1][i][j]=0;
			}
		}
		printf("%d\n",f(0,0));
	}
}

刚开始提交代码时,编译器提示运行超时。后来跟同学讨论怎么优化这个代码,就是在注释部分加的代码,记录已经计算过的点的值,这样可以避免每次搜索的时候都去把这些点都计算一遍。

提交后发现这个代码居然排到了第三名,很开心呀




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值