CSU1604 sunnypig

Description

SunnyPig is a pig who is much cleverer than any other pigs in the pigpen. One sunny morning, SunnyPig wants to go out of the pigpen to date Mrs. Snail, his beloved. However, it’s terribly tough for a pig to go out of the pigpen because the pigpen is divided into m * n grids with fences which pigs cannot go across. Luckily, there are some doors unlocked on the fences so that SunnyPig can push them open with his nose. Since SunnyPig is a pig, no matter how clever he is, he can never walk upright like human beings. As a result, SunnyPig is not able to pull any doors.
Now give you the map of the pigpen, please calculate the fewest number of doors SunnyPig should push to go out of the pigpen.

Input

The first line there is a number T (0 < T < 100), denoting the number of the test case.
The first line of each test case has only two numbers: m, n.
The following 2*m+1 lines describe the pigpen. Each line has 2*n+1 characters. ’*’ represents a cross point of two fences. ’O’ represents the initial position SunnyPig. ’-’ and ‘|’ represent fences without doors. ’N’, ’S’, ’W’, ’E’ represent the doors SunnyPig can push in the direction of north, south, west and east respectively. And the character of a space represents the place where SunnyPig can go through.

Output

Output the fewest number of doors SunnyPig should push to go out of the pigpen, in other words, the fewest number of doors SunnyPig should push to go out of the border of these grids.
If SunnyPig cannot go out of the pigpen, output -1. Each case, a single line.

Sample Input

<span class="sampledata">2
3 3
*-*N*-*
|O| E E
*S*S*-*
W | E |
*-*S*N*
W W E |
*N*S*N*
4 2
*N*S*
E | W
*S*S*
EOW W
*-*N*
| W E
*-*S*
W E |
*S*S*</span>

Sample Output

<span class="sampledata">2
</span><p><span class="sampledata">-1</span></p><p><span class="sampledata">第一次跟学长们打比赛,很轻松地被虐了。除了最后两道水题,这一道是我觉得最简单的,dfs和bfs都用了,可是错了八次还是没过,╮(╯▽╰)╭。。。第二天再看了别人的解题报告,原来是漏了一个条件:一定是从门出去的。。。</span></p><p>下面是代码</p><p><pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
#define maxN 2000+5
int n,m,p[maxN][maxN],d[5][2]={{0,0},{0,1},{0,-1},{1,0},{-1,0}},sx,sy;
int a[maxN][maxN];
struct node
{
    int x,y,ans;
};
int jud(int x,int y)
{
    if(!p[x][y]&&a[x][y]!=-1&&x>0&&y>0&&x<=n&&y<=m)
        return 1;
    return 0;
}
int out(int x,int y)
{
    if(x==0||y==0||x==n+1||y==m+1)
        return 1;
    return 0;
}
void bfs()
{
    queue<node> q;
    node cur,next;
    memset(p,0,sizeof(p));
    p[sx][sy]=1;
    cur.x=sx,cur.y=sy,cur.ans=0;
    q.push(cur);
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        //printf("%d %d\n",cur.x,cur.y);
        for(int i=1;i<=4;i++)
        {
            int dx=cur.x+d[i][0];
            int dy=cur.y+d[i][1];
            if(jud(dx,dy))
            {
                next.x=dx,next.y=dy;
                if(a[dx][dy]==i)
                {
                    if(out(dx+d[i][0],dy+d[i][1]))
                    {
                        printf("%d\n",cur.ans+1);
                        return ;
                    }
                    next.ans=cur.ans+1;
                    p[next.x][next.y]=1;
                    q.push(next);
                }
                else if(a[dx][dy]==0)
                {
                    next.ans=cur.ans;
                    p[next.x][next.y]=1;
                    q.push(next);
                }
            }
        }
    }
    printf("-1\n");
}
int main()
{
    int t,i,j;
    char str[maxN];
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        scanf("%d%d\n",&n,&m);
        n=2*n+1,m=2*m+1;
        for(i=1;i<=n;i++)
        {
            gets(str+1);
            for(j=1;j<=m;j++)
            {
                if(str[j]=='*'||str[j]=='|'||str[j]=='-')
                    a[i][j]=-1;
                if(str[j]=='E')
                    a[i][j]=1;
                if(str[j]=='W')
                    a[i][j]=2;
                if(str[j]=='S')
                    a[i][j]=3;
                if(str[j]=='N')
                    a[i][j]=4;
                if(str[j]==' ')
                    a[i][j]=0;
                if(str[j]=='O')
                {
                    sx=i,sy=j;
                    a[i][j]=0;
                }
            }
        }
        bfs();
    }
    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值