1795 Problem A Fibonacci

问题 A: Fibonacci

时间限制: 1 Sec  内存限制: 32 MB
提交: 230  解决: 72
 

题目描述

The Fibonacci Numbers{0,1,1,2,3,5,8,13,21,34,55...} are defined by the recurrence: 
F0=0 F1=1 Fn=Fn-1+Fn-2,n>=2 
Write a program to calculate the Fibonacci Numbers.

输入

Each case contains a number n and you are expected to calculate Fn.(0<=n<=30) 。

输出

For each case, print a number Fn on a separate line,which means the nth Fibonacci Number.

样例输入

1

样例输出

1

经验总结

这种题目我就不说话了。。直接上代码0.0

正确代码

#include <cstdio>
const int maxn=60;
int dp[maxn];

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		dp[0]=0;
		dp[1]=1;
		for(int i=2;i<=n;++i)
		{
			dp[i]=dp[i-1]+dp[i-2];
		}
		printf("%d\n",dp[n]);
	}
    return 0;
}

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值