1961 Problem D Coincidence

问题 D: Coincidence

时间限制: 1 Sec  内存限制: 32 MB
提交: 34  解决: 16
 

题目描述

Find a longest common subsequence of two strings.

输入

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

输出

For each case, output k – the length of a longest common subsequence in one line.

样例输入

google
goodbye

样例输出

4

经验总结

求最长公共子序列(LCS),经典的动态规划问题,状态转移方程 dp[ i ] [ j ] =   dp[ i - 1 ] [ j - 1 ] + 1  ( if s [ i ] = = s [ j ] )
                                                                                                                    max ( dp[ i - 1 ] [ j ],dp [ i ] [ j - 1] ) ( if s [ i ] ! = s [ j ] )

就不多说啦( •́ .̫ •̀ )

正确代码

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=110;
int dp[maxn][maxn];
char s1[maxn],s2[maxn];

int main()
{
	int n;
	while(~scanf("%s",s1+1))
	{
		scanf("%s",s2+1);
		int len1=1,len2=1;
		while(s1[len1]!='\0')
			++len1;
		--len1;
		while(s2[len2]!='\0')
			++len2;
		--len2;
		for(int i=0;i<=len1;++i)
		{
			dp[i][0]=0;
		}
		for(int i=0;i<=len2;++i)
		{
			dp[0][i]=0;
		}
		for(int i=1;i<=len1;++i)
			for(int j=1;j<=len2;++j)
			{
				if(s1[i]==s2[j])
				{
					dp[i][j]=dp[i-1][j-1]+1;
				}
				else
				{
					dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
				}
			}
		printf("%d\n",dp[len1][len2]);
	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值