PAT 甲级 1071  Speech Patterns

1071 Speech Patterns (25 point(s))

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

经验总结:

这一题,题目本身不是很难,直接定义一个string变量利用getline() 读入一行然后依次遍历利用map<string,int> 映射进行记录,最后输出字典序最小的出现次数最多的那个单词即可,当然,如果为了追求速度,可以使用读入优化以及输出优化,读入优化效果很明显,而且比较适合使用,下面的代码就是利用了读入优化与输出优化,欢迎大佬指正呀(●′ω`●)~

AC代码

#include <cstdio>
#include <cstring>
#include <map>
#include <string>
using namespace std;
void print(int x)
{
	if(x>9)
		print(x/10);
	putchar(x%10+'0');
}
int main()
{
	char c=getchar();
	map<string,int> mp;
	int maxnum=-1;
	while(c!='\n')
	{
		string temp;
		while(!isalnum(c))
		{
			c=getchar();
			if(c=='\n')
				break;
		}
		while(isalnum(c))
		{
			temp+=c>=65&&c<=90?c+32:c;
			c=getchar();
		}
		mp.count(temp)==0?mp[temp]=1:++mp[temp];
		maxnum=maxnum>mp[temp]?maxnum:mp[temp];
	}
	for(map<string,int>::iterator it=mp.begin();it!=mp.end();++it)
	{
		if(it->second==maxnum)
		{
			for(int i=0;i<it->first.size();++i)
				putchar(it->first[i]);
			putchar(' ');
			print(maxnum);
			break;
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值