PAT 甲级 1088  Rational Arithmetic

1088 Rational Arithmetic (20 point(s))

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

经验总结:

这一题,就是基本的分数运算,不过有一个坑点,那就是不能将分子分母定义为整型,因为题目虽然说所有的数都在长整型的范围内,但是进行分数乘法,分子分母就会超出整型范围,所以必须将其定义为long long int ,而且相应的求最大公约数以及求绝对值函数的参数类型还有输出与输入控制都需要进行修改~

AC代码

#include <cstdio>
#include <cstring>
typedef long long LL;
struct fraction
{
	LL up,down;
};
LL gcd(LL a,LL b)
{
	return !b?a:gcd(b,a%b);
}
LL abs(LL a)
{
	return a>0?a:-a;
}
fraction reduct(fraction a)
{
	if(a.down<0)
	{
		a.down=-a.down;
		a.up=-a.up;
	}
	if(a.up==0)
		a.down=1;
	else
	{
		LL g=gcd(abs(a.up),a.down);
		a.up/=g;
		a.down/=g;
	}
	return a;
}
fraction add(fraction a,fraction b)
{
	fraction res;
	res.up=a.up*b.down+b.up*a.down;
	res.down=a.down*b.down;
	return reduct(res);
}
fraction sub(fraction a,fraction b)
{
	fraction res;
	res.up=a.up*b.down-b.up*a.down;
	res.down=a.down*b.down;
	return reduct(res);
}
fraction mul(fraction a,fraction b)
{
	fraction res;
	res.up=a.up*b.up;
	res.down=a.down*b.down;
	return reduct(res);
}
fraction dev(fraction a,fraction b)
{
	fraction res;
	res.up=a.up*b.down;
	res.down=a.down*b.up;
	return reduct(res);
}
void show(fraction a)
{
	a=reduct(a);
	if(a.down==0)
		printf("Inf");
	else
	{
		if(a.up<0)
			printf("(");
		if(a.down==1)
			printf("%lld",a.up);
		else
		{
			if(abs(a.up)>a.down)
				printf("%lld %lld/%lld",a.up/a.down,abs(a.up)%a.down,a.down);
			else
				printf("%lld/%lld",a.up,a.down);
		}
		if(a.up<0)
			printf(")");
	}
}
int main()
{
	fraction a,b;
	scanf("%lld/%lld %lld/%lld",&a.up,&a.down,&b.up,&b.down);
	show(a);printf(" + ");show(b);printf(" = ");show(add(a,b));putchar('\n');
	show(a);printf(" - ");show(b);printf(" = ");show(sub(a,b));putchar('\n');
	show(a);printf(" * ");show(b);printf(" = ");show(mul(a,b));putchar('\n');
	show(a);printf(" / ");show(b);printf(" = ");show(dev(a,b));putchar('\n');
	return 0;
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值