线段树(需离散化)之poj2528

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33094 Accepted: 9618

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4


#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;

#define lz 2*u,l,mid
#define rz 2*u+1,mid+1,r
const int maxn=20005;
int flag[4*maxn];
int A[maxn], B[2*maxn];
int visit[2*maxn];
int ans=0;

struct node
{
    int l, r;
} f[maxn];

void build(int u, int l, int r)
{
    flag[u]=0;
    if(l==r)  return ;
    int mid=(l+r)>>1;
    build(2*u,l,mid);
    build(2*u+1,mid+1,r);
}

void Update(int u, int l, int r, int tl, int tr, int c)
{
    if(flag[u]) return ;  //此段已经贴满了海报,不必再查询下去了
    if(tl<=l&&r<=tr)//如果张贴的海报左右端点的区间,大于树的区间
    {
        flag[u]=1;  //标记该段区间已经被覆盖过了
        if(!visit[c])
        {
            ans++;
            visit[c]=1;
        }
        return ;
    }
    int mid=(l+r)>>1;
    if(tr<=mid) Update(lz,tl,tr,c);
    else if(tl>mid) Update(rz,tl,tr,c);
    else
    {
        Update(lz,tl,mid,c);
        Update(rz,mid+1,tr,c);
    }
    if(flag[2*u]&&flag[2*u+1]) flag[u]=1; ///!!标记上传
}

int getid(int x, int n)
{
    int l=1, r=n, mid;
    while(l<=r)
    {
        mid=(l+r)>>1;
        if(B[mid]==x) return mid;
        else if(B[mid]<x) l=mid+1;
        else r=mid-1;
    }
}

int main()
{
    int T, n;
    cin >> T;
    while(T--)
    {
        cin >> n;
        memset(visit,0,sizeof(visit));
        int num=0;
        for(int i=0; i<n; i++)//将端点保存在A数组中
        {
            scanf("%d%d",&f[i].l,&f[i].r);
            A[++num]=f[i].l;
            A[++num]=f[i].r;
        }
        sort(A+1,A+num+1);//对A数组排序
        int ep=1;
        B[1]=A[1];
        for(int i=2; i<=num; i++)  //把A中重复的去掉,通过数组下标与数组的值建立映射
            if(B[ep]!=A[i]) B[++ep]=A[i];
        for(int i=ep; i>1; i--)//如果相邻数字间距大于1的话,在其中加上任意一个数字
            if(B[i]!=B[i-1]+1) B[++ep]=B[i-1]+1;
        sort(B+1,B+ep+1);//排序
        build(1,1,ep);
        ans=0;
        for(int i=n-1; i>=0; i--)
        {
            int l=getid(f[i].l,ep);//通过值映射到下标
            int r=getid(f[i].r,ep);
            Update(1,1,ep,l,r,i+1);
        }
        printf("%d\n",ans);
    }
    return 0;
}
转载注明出处:http://www.cnblogs.com/kane0526/archive/2013/03/11/2952952.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值