第一发博客

       今天是第一天集训开始,心情是激动的,也是非常开心。。学长先是讲了指针,,实际上没明白多少还是得靠自学。以前以为自学的人都很流弊,到了大学才明白全是靠自学的。也是有点小开心,,我想我应该能坚持到最后,不放弃。吉首大学的生活感觉还是挺好的。。在这次集训中我要尽量多学知识。。既然选了这门专业就该好好学。对没错是这样的。来发题目玩玩杭电1009

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46454    Accepted Submission(s): 15580


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


 

Sample Input
  
  
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1


 

Sample Output
  
  
13.333 31.500
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

struct p
{
    int mao;
    int cost;
    double aver;
}num[1005];

bool cmp(p x,p y)
{
    return x.aver>y.aver;
}

int main()
{
    int money,n;
    while(~scanf("%d %d",&money,&n))
    {
        if(money==-1)break;
        double sum=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d %d",&num[i].mao,&num[i].cost);
            num[i].aver=num[i].mao*1.0/num[i].cost;
        }
        sort(num,num+n,cmp);
        for(int i=0;i<n;i++)
        {
            if(money<=num[i].cost)
            {
                sum+=money*num[i].aver;
                break;
            }
            else
            {
                sum+=num[i].mao;
                money-=num[i].cost;
            }
        }
        printf("%.3f\n",sum);
    }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值