HDU1133 Buy the Ticket (卡特兰数)

Buy the Ticket

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7990    Accepted Submission(s): 3327


 

Problem Description

The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person.
Note: initially the ticket-office has no money.

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.

 

 

Input

The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.

 

 

Output

For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.

 

 

Sample Input

 

3 0 3 1 3 3 0 0

 

 

Sample Output

 

Test #1: 6 Test #2: 18 Test #3: 180

 

 

Author

HUANG, Ninghai

 

 

Recommend

Eddy

 题目意思是买票,票价50,但买票的地方没有钱,现在有拿着50块的m人和拿着100块的n人来,问你有多少种方法可以满足

找零。

所以  当 n>m 直接输出0

当 n<=m 

intput   output

3  0      6

3  1      18

3  3      180

由卡特兰数那个图

                                                                转自百度

可以看出 t[m][n]=a[n][m]*n!*m! (因为图是从下往上的所以n,m换了位置)

m,n都是100以内的阶乘都会变成大数,想着用c写就头皮发麻 =-=

学了一下java的大数 写了第一个java程序 a了这道题。

ac代码 

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
        BigInteger c[][] = new BigInteger[110][110]; 
        for ( int i = 0 ; i <= 100 ; i++ ) 
            for ( int j = 0 ; j <= 100 ; j++ ) c[i][j] = BigInteger.valueOf(0); 
		c[0][0]=BigInteger.valueOf(1);
		for(int i=0;i<=100;i++)
		   for(int j=i;j<=100;j++){
		   	   if(i==0) {
		   		   if(j!=0)c[i][j]=c[i][j].add(c[i][j-1]);
		   	   }
		   	   else {
		   		   c[i][j]=c[i][j].add(c[i][j-1]);
		   		   c[i][j]=c[i][j].add(c[i-1][j]);
		   	   }
		   } 
		int digit=1;
		while(in.hasNext()) {
			int a=in.nextInt();
			int b=in.nextInt();
			if(a==0)return ;
			BigInteger t1 = BigInteger.valueOf(1);
			BigInteger t2 = BigInteger.valueOf(1);
			for(int i=1;i<=a;i++)
			t1 = t1.multiply(BigInteger.valueOf(i));
			for(int i=1;i<=b;i++)
			t2 = t2.multiply(BigInteger.valueOf(i));
			t2 = t2.multiply(c[b][a]);
			t1 = t1.multiply(t2);
			System.out.println("Test #"+digit+":");
			System.out.println(t1);
			digit++;
		}	
	    }
	}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值