Game (子串问题 模板)

Problem Description

Alice and Bob is playing a game.

Each of them has a number. Alice’s number is A, and Bob’s number is B.

Each turn, one player can do one of the following actions on his own number:

1. Flip: Flip the number. Suppose X = 123456 and after flip, X = 654321

2. Divide. X = X/10. Attention all the numbers are integer. For example X=123456 , after this action X become 12345(but not 12345.6). 0/0=0.

Alice and Bob moves in turn, Alice moves first. Alice can only modify A, Bob can only modify B. If A=B after any player’s action, then Alice win. Otherwise the game keep going on!

Alice wants to win the game, but Bob will try his best to stop Alice.

Suppose Alice and Bob are clever enough, now Alice wants to know whether she can win the game in limited step or the game will never end.

 Input

First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

For each test case: Two number A and B. 0<=A,B<=10^100000.

 Output

For each test case, if Alice can win the game, output “Alice”. Otherwise output “Bob”.

 Sample Input

4
11111 1
1 11111
12345 54321
123 123

 Sample Output

Alice
Bob
Alice
Alice

 Hint

For the third sample, Alice flip his number and win the game.

For the last sample, A=B, so Alice win the game immediately even nobody take a move.

题意:Alice简化为A,Bob简化为B,A,B各有2个属于他们自己的数字,通过2种方法 1.数字串翻转,2.数字串/10,且仍为整数,A先B后,判断A是否可以与B相同,如果可以A 赢 否则B赢。

思路:判断是否为子串,如果是倒叙的子串也可以。

附上水过数据弱的代码:

[cpp]  view plain  copy
  1. #include<iostream>  
    #include<cstdio>  
    #include<algorithm>  
    #include<cstring>  
    using namespace std;  
    char a[1000005],b[1000005];  
    int suma[15],sumb[15];  
    int main()  
    {  
        int n;  
        scanf("%d",&n);  
        while(n--)  
        {  
           scanf("%s%s",a,b);  
           int la=strlen(a),lb=strlen(b),flag=1;  
           memset(suma,0,sizeof(suma));  //将数组suma初始化为0 
           memset(sumb,0,sizeof(sumb));  
           if(la>=lb&&flag)
           {  
               for(int i=0;i<la;i++)  
                 suma[a[i]-'0']++; //将字符型转化为整形 
              for(int i=0;i<lb;i++)  
                 sumb[b[i]-'0']++;  
             for(int i=0;i<=9;i++){  
               if(suma[i]<sumb[i]){  //i字符的个数 
                   flag=0;  
                   break;  
               }  
             }  
             if(sumb[0]>0)  
             {  
               for(int i=1;i<=9;i++){  
                 if(sumb[i]==0){  
                    flag=1;  
                    break;  
                 }  
              }  
             }  
      
           }  
           else  
            flag=0;  
           if(flag)  
             printf("Alice\n");  
           else  
             printf("Bob\n");  
      }  
        return 0;  
    }  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值