Open the Lock

Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9. Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step. Now your task is to use minimal steps to open the lock. Note: The leftmost digit is not the neighbor of the rightmost digit.
 

Input
The input file begins with an integer T, indicating the number of test cases. Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
 

Output
For each test case, print the minimal steps in one line.
 

Sample Input
  
  
2 1234 2144 1111 9999
 

Sample Output
  
  
2 4
 

Author
YE, Kai
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
int f[10],a[10],b[10],mx;
int fun(int m)
{
    int sum,c[]={m/1000,m/100%10,m/10%10,m%10};
    for(int i=sum=0;i<4;i++)
    {
        if(abs(c[i]-b[i])<5)sum+=abs(c[i]-b[i]);
        else sum+=9-abs(c[i]-b[i]);
    }
    return sum;
}
int dfs(int sum,int temp)
{
    if(sum>999)
    {
        int i=fun(sum)+temp;
        if(mx>i)mx=i;
        return 0;
    }
    for(int i=0;i<4;i++)
    {
        if(!f[i])
        {
            f[i]=1;
            dfs(sum*10+a[i],temp++);
            f[i]=0;
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
      scanf("%1d%1d%1d%1d",&a[0],&a[1],&a[2],&a[3]);
      scanf("%1d%1d%1d%1d",&b[0],&b[1],&b[2],&b[3]);
    mx=10000;
    dfs(0,0);
    printf("%d\n",mx);
    }
   return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值