HDOJ 1061 Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43051    Accepted Submission(s): 16181


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L
 

Recommend

We have carefully selected several similar problems for you:  1021 1008 1019 1071 1108 


我用同余定理它超时了。

实在想不出别的方法只好找题解。

结果发现居然能找规律找出来……我的思维能力太差了(捂脸


#include<stdio.h>
int digit[25]={0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int a;
		scanf("%d",&a);
		printf("%d\n",digit[a%20]);
	}	
	return 0;
}

7.22

原来这道题是快速幂的模板题……那些找规律做出来的人是有多厉害啊= =

补上快速幂模板,代码如下


#include<stdio.h>
#include<string.h>
#include<math.h>
int pm(int x)
{
	int ans=1;
	int num=x;
	x%=10;
	while(num)
	{
		if(num&1)
			ans=ans*x%10;
		x=x*x%10;
		num>>=1;
	}
	return ans;
}
int main()
{
	int T,n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		printf("%d\n",pm(n));
	}
	return 0;
}

2016.8.9

补上快速幂的定义:

快速幂顾名思义,就是快速算某个数的多少次幂。其时间复杂度为 O(log₂N)

关于快速幂的学习:1  2

主要就是二进制问题,实在不会的话可以强行背模板……_(:з」∠)_

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值