HDOJ 2136 Largest prime factor

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9250    Accepted Submission(s): 3268


Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 

Input
Each line will contain one integer n(0 < n < 1000000).
 

Output
Output the LPF(n).
 

Sample Input
  
  
1 2 3 4 5
 

Sample Output
  
  
0 1 2 1 3
 

Author
Wiskey
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2138  2133  2135  1215  2137 
 

很有意思的一道题,更加理解素数打表原理。

前两天做的好像没传上来,今天扔上来。


#include<stdio.h>
#include<string.h>
#define Max 1000001
int a[Max];
void S()
{
    int i,j;
    int k=1;
    memset(a,0,sizeof(a));
    for(i=2;i<Max;i++)
    {
        if(!a[i])
            a[i]=k++;
        for(j=i+i;j<Max;j+=i)
            a[j]=a[i];
    }
}
int main()
{
    S();
    int n;
    while(~scanf("%d",&n))
        printf("%d\n",a[n]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值