HDU 1051 Wooden Sticks (贪心,嵌套区间个数 )

Wooden Sticks

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3
题目不难懂,直接上AC代码。思路见代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
struct STRICK
{
    int len;
    int weig;
};
STRICK a[5010];
bool cmp(STRICK x,STRICK y)
{
    if(x.len != y.len) return x.len < y.len;
    else     return x.weig < y.weig ;
}
int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {   //贪心原则,按len 从小到到大排序。比较weight
        //发现只有两个区间嵌套时,需要多加1分钟。题目转化为:嵌套区间个数 
        scanf("%d",&n);
        for(int i = 0 ; i < n ; i ++)
        {
            scanf("%d%d",&a[i].len,&a[i].weig);
        }
        sort(a,a + n,cmp);
        int time = 1 ;                  //时间
        int k = 0;                      //记录内嵌区间位置
        int flag = 1;                   //扫描区间的个数
        while(1)
        {
            int f = 1 ;
            int end = a[k].weig;        //下一个起点区间
            a[k].weig = 0;              //如果扫描过,记录为0
            for(int j = k+1 ; j < n ; j ++)
            {
                if(a[j].weig >= end && a[j].weig )  // 题目要求:l<=l' and w<=w'. 且区间没有扫描
                {
                    end = a[j].weig;
                    a[j].weig = 0;
                    flag ++;
                }
                else
                {
                    if(f && a[j].weig)   //且区间没有扫描过
                    {
                    k = j;              //记录第一个内嵌区间位置
                    time ++;
                    f = 0;
                    flag ++;
                    }
                }
            }
            if(flag == n)               //如果区间全部扫描完
            break;
        }
        printf("%d\n",time);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值