android6.0不支持Httpclient的解决方法

Android 的 6.0 版本中移除对 Apache HTTP 客户端的支持,使用HttpURLConnection类来代替。此 API 是效率更高,因为它减少了网络使用通过透明的压缩和响应缓存,并将功耗降至最低。要继续使用 Apache HTTP Api,您必须先声明以下的编译时依赖项在build.gradle文件中:

android {
    useLibrary 'org.apache.http.legacy'
}
展开阅读全文

没有更多推荐了,返回首页