hdu 1789Doing Homework again(贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8129    Accepted Submission(s): 4789


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
2007省赛集训队练习赛(10)_以此感谢DOOMIII

虽然可以想到要用贪心来解,但是自己还是想不出来。。        可以先将扣分按照高到低排序,然后将最高的分放到其所对应的最后期限里面,如果那天已经没空了,就提前一天,以此类推,直到放下为止。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct deadline{
    int day,score;
}p[1005];
bool cmp(deadline a,deadline b)
{
   return a.score>b.score;
      
}
int main()
{
    int n,i,j,k,tot,T,a[1003];
    scanf("%d",&T);
    while(T--)
    {
        tot=0;
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%d",&p[i].day);
        for(i=0;i<n;i++)
        scanf("%d",&p[i].score);
        sort(p,p+n,cmp);
        for(i=0;i<n;i++)
        {
            if(!a[p[i].day]){
                a[p[i].day]=1;
                p[i].score=-1;
            }
            else {
                for(j=p[i].day-1;j>0;j--)
                {
                    if(!a[j]){
                        a[j]=1;
                        p[i].score=-1;
                        break;
                    }
                }
            }
        }
        for(i=0;i<n;i++)
        {
            if(p[i].score!=-1)tot=tot+p[i].score;
        }
        printf("%d\n",tot);
    }    
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值