poj1258 Agri-Net +hdu 1233 还是畅通工程 (最小生成树Prime算法)

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 43215 Accepted: 17683

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

USACO 102

代码:
#include<stdio.h>
#include<string.h>
#define MAX 99999999
int mat[105][105];
int main()
{
    int n,i,j,k,sum,vis[1005],a,b,c,dist[105];
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        memset(vis,0,sizeof(vis));
        for(i=0;i<105;i++)
        for(j=0;j<105;j++)
        mat[i][j]=MAX;
        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        {
    scanf("%d",&a);
    mat[i][j]=a;
        }
        vis[1]=1;
        dist[1]=0;
        sum=0;
        int pos=1;
    
        for(i=2;i<=n;i++)
        {
         dist[i]=mat[1][i];
        }

    
        for(i=1;i<n;i++)
        {
            int mini=MAX,u=-1;
            for(j=1;j<=n;j++)
            if(!vis[j]&&dist[j]<mini)
            {
                u=j;mini=dist[j];
            }
            vis[u]=1;
            sum=sum+dist[u];
            for(j=1;j<=n;j++)
            if(!vis[j]&&dist[j]>mat[u][j])dist[j]=mat[u][j];
        }
        printf("%d\n",sum);
    }
    return 0;
}

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29993    Accepted Submission(s): 13396


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
   
   
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
   
   
3 5
Hint
Hint
Huge input, scanf is recommended.
 

Source
代码:
#include<stdio.h>
#include<string.h>
#define MAX 99999999
int mat[105][105];
int main()
{
    int n,i,j,k,sum,vis[1005],a,b,c,dist[105];
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        memset(vis,0,sizeof(vis));
        for(i=0;i<105;i++)
        for(j=0;j<105;j++)
        mat[i][j]=MAX;
        for(i=1;i<=n*(n-1)/2;i++)
        {
        scanf("%d%d%d",&a,&b,&c);
        mat[a][b]=mat[b][a]=c;
        }
        vis[1]=1;
        dist[1]=0;
        sum=0;
        int pos=1;
    
        for(i=2;i<=n;i++)
        {
         dist[i]=mat[1][i];
        }

    
        for(i=1;i<n;i++)
        {
            int mini=MAX,u=-1;
            for(j=1;j<=n;j++)
            if(!vis[j]&&dist[j]<mini)
            {
                u=j;mini=dist[j];
            }
            vis[u]=1;
            sum=sum+dist[u];
            for(j=1;j<=n;j++)
            if(!vis[j]&&dist[j]>mat[u][j])dist[j]=mat[u][j];
        }
        printf("%d\n",sum);
    }
    return 0;
}
两题都是最简单的最小生成树prime算法的套用。。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值