poj 2796 Feel Good(单调栈)

Feel Good
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11148 Accepted: 3059
Case Time Limit: 1000MS Special Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

Source

Northeastern Europe 2005


题目大意:在一段区间里面,求出在这段区间里面(最小值*区间之和)的最大值。

思路:利用单调栈,求出一个数所能扩展到的区间,进行运算。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<stack>
#define LL __int64
using namespace std;
struct node{
	LL num,pre,next,k;
};
LL a[100005],sum[100005];
int main()
{
	stack<node>Q;
	node tmp;
	int i,j,n;
	LL ans,sum1,x,y;
	while(scanf("%d",&n)!=EOF)
	{
		sum[0]=0;
		ans=sum1=-100;
		for(i=1;i<=n;i++)
		{
		scanf("%I64d",&a[i]);
		if(i==1)sum[i]=a[i];
		else sum[i]=sum[i-1]+a[i];
	}
	tmp.num=a[1];
	tmp.pre=1;
	tmp.next=1;
	tmp.k=1;
	Q.push(tmp);
	for(i=2;i<=n;i++)
	{
		node tmp1;
		tmp1.num=a[i];
		tmp1.pre=1;
		tmp1.next=1;
		tmp1.k=i;
		while(!Q.empty()&&tmp1.num<=Q.top().num)
		{
			tmp=Q.top();
			Q.pop();
			if(!Q.empty())
          Q.top().next+=tmp.next;
			tmp1.pre+=tmp.pre;
			ans=tmp.num*(sum[tmp.next+tmp.k-1]-sum[tmp.k-tmp.pre]);
			if(ans>=sum1){
				sum1=ans;
				x=tmp.k-tmp.pre+1;
				y=tmp.next+tmp.k-1;
			}
		}
		Q.push(tmp1);
		
	}
	while(!Q.empty()){
		tmp=Q.top();
		Q.pop();
		if(!Q.empty())
		Q.top().next+=tmp.next;
		ans=tmp.num*(sum[tmp.next+tmp.k-1]-sum[tmp.k-tmp.pre]);
		if(ans>=sum1){
			sum1=ans;
			x=tmp.k-tmp.pre+1;
			y=tmp.next+tmp.k-1;
		}
	}
	printf("%I64d\n%I64d %I64d\n",sum1,x,y);
	}
}

技术选型 【后端】:Java 【框架】:springboot 【前端】:vue 【JDK版本】:JDK1.8 【服务器】:tomcat7+ 【数据库】:mysql 5.7+ 项目包含前后台完整源码。 项目都经过严格调试,确保可以运行! 具体项目介绍可查看博主文章或私聊获取 助力学习实践,提升编程技能,快来获取这份宝贵的资源吧! 在当今快速发展的信息技术领域,技术选型是决定一个项目成功与否的重要因素之一。基于以下的技术,我们为您带来了一份完善且经过实践验证的项目资源,让您在学习和提升编程技能的道路上事半功倍。以下是该项目的技术选型和其组件的详细介绍。 在后端技术方面,我们选择了Java作为编程语言。Java以其稳健性、跨平台性和丰富的库支持,在企业级应用中处于领导地位。项目采用了流行的Spring Boot框架,这个框架以简化Java企业级开发而闻名。Spring Boot提供了简洁的配置方式、内置的嵌入式服务器支持以及强大的生态系统,使开发者能够更高效地构建和部署应用。 前端技术方面,我们使用了Vue.js,这是一个用于构建用户界面的渐进式JavaScript框架。Vue以其易上手、灵活和性能出色而受到开发者的青睐,它的组件化开发思想也有助于提高代码的复用性和可维护性。 项目的编译和运行环境选择了JDK 1.8。尽管Java已经推出了更新的版本,但JDK 1.8依旧是一种成熟且稳定的选择,广泛应用于各类项目中,确保了兼容性和稳定性。 在服务器方面,本项目部署在Tomcat 7+之上。Tomcat是Apache软件基金会下的一个开源Servlet容器,也是应用最为广泛的Java Web服务器之一。其稳定性和可靠的性能表现为Java Web应用提供了坚实的支持。 数据库方面,我们采用了MySQL 5.7+。MySQL是一种高效、可靠且使用广泛的关系型数据库管理系统,5.7版本在性能和功能上都有显著的提升。 值得一提的是,该项目包含了前后台的完整源码,并经过严格调试,确保可以顺利运行。通过项目的学习和实践,您将能更好地掌握从后端到前端的完整开发流程,提升自己的编程技能。欢迎参考博主的详细文章或私信获取更多信息,利用这一宝贵资源来推进您的技术成长之路!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值