POJ 2001 Shortest Prefixes

这题看了好久都没看懂,只知道是用字典树写,后来问了一下同学才明白题意,结果当然很快就A了。
该题目的意思就是输入一系列字符串,然后查找逐个字符串,看看最多要搜多长才能确定是该字符串。
                                                                                                         Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5829 Accepted: 2403

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

下面贴代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define max 26

typedef struct node  //字典树节点信息
{
   struct node * next[max];
   int flag;  //记录字母出现的次数
}node, * Node;
Node  root;  //根节点
char str[1000][25], sub[1000][25];  //str[][]记录输入的字符串,sub[][]记录前缀字符串

void insert(char * str)  //建树
{
   int i, len, index;
   Node current, newnode;
   len = strlen(str);
 
   if(len == 0)
      return ;
  
   current = (Node) calloc (1, sizeof(node));  //分配空间
   current = root;
 
   for(i = 0; i < len; i ++)
   {
      index = str[i] - 'a';  //寻找该字符存放的位置
      if(current->next[index] != NULL)  //如果该字符已存在
      {
         current = current->next[index];
         (current->flag) ++;  //该字符出现的次数加1
       }
      else   //如果该字符不存在,新增一个节点
      {
         newnode = (Node) calloc (1, sizeof(node));  //分配空间
         current->next[index] = newnode;  //指针移动
         current = newnode;
         current->flag = 1;  //出现次数赋为1
      }
   }
 
}

void find(char * str, char * sub)  //找前缀
{
   int i, index, len;
   Node current;
 
   len = strlen(str);
   current = (Node) calloc (1, sizeof(node));  //分配空间
   current = root;
 
   for(i = 0; i < len; i ++)
   {
      index = str[i] - 'a';  //寻找该字符所在的下标
      current = current->next[index];
      sub[i] = str[i];  //赋值
  
      if(current->flag == 1)  //判断是否已为该串所特有
      {
         i ++;
         sub[i] = str[i];
         sub[i ++] = '\0';
         return ;
      }
    }
 
   sub[i] = '\0';
}

int main()
{
   int j, i = 0;
   root = (Node) calloc (1, sizeof(node));
 
   while(scanf("%s", str[i]) != EOF)  //输入
   {
      insert(str[i]);
      i ++;
   }
 
   for(j = 0; j < i; j ++)  //查找
   {
      find(str[j], sub[j]);
   }
 
   for(j = 0; j < i; j ++)  //输出
   {
      printf("%s %s\n", str[j], sub[j]);
   }
 
     return 0;
}

 

转载于:https://www.cnblogs.com/Mr_Lai/archive/2010/11/26/1889270.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值